跳到主要内容

域名绑定常见问题

开发版应用无法在 LeanCloud 备案吗?​

由于我们运营人员有限,我们无法协助开发版应用办理新增备案。

建议考虑通过其他方式来继续使用我们的服务,如:

  • 转入 LeanCloud 国际版,国际版无需绑定域名,也无需备案。
  • 到 IaaS 服务商处自行完成备案和接入。我们华北节点是和 UCloud 合作,华东节点是和腾讯云合作,大家可以按照应用的节点选择合适的 IaaS 服务商去备案。
  • 升级为商用版。

老版本的客户端怎么办?​

对于绑定了自有域名的应用,其老版本的客户端由于不能及时升级的原因,还会继续使用 LeanCloud 原来提供的共享域名。 我们目前还支持这些请求,以便兼容老版本的客户端。 但共享域名不保证可用性,未来我们也计划下线共享域名,还请尽快升级客户端。

开启 HTTPS 的域名,其 SSL 证书如何处理?​

API 自定义域名必须开启 HTTPS。 云引擎自定义域名和文件服务自定义域名,HTTPS 是可选项。

如果启用 HTTPS,我们提供了两种方式 SSL 证书配置方式:

  • 开发者手动上传自己的证书,在证书到期前自行续期证书并重新上传。
  • 自动为该域名申请并维护 Let's Encrypt 证书。

选择哪种方式,开发者可以自行决定。

不同应用之间可以使用同一个子域名吗?​

不同应用无法使用相同的子域名。

应用在开发版和商用版之间切换,对于域名绑定会有什么影响吗?​

域名绑定不受开发版、商用版切换影响。

应用转让对于域名绑定会有什么影响吗?​

应用转让之后,如果原域名所有者不删除 DNS 解析记录,那么所有的请求还是会打到 LeanCloud 后端集群上来,这些请求都会被正常处理。如果原域名所有者删除了 DNS 解析记录,而新的开发者又不绑定到新的域名,那么理论上使用原域名访问的流量是根本不会到达 LeanCloud 集群的,这时候被转让的应用基本上就处于不可用状态了。

如果应用的新所有者需要更换域名,可以采取先新增绑定、后删除老域名的方式来操作。 同一个应用的同一种服务支持绑定多个访问域名,以便开发者需要切换域名的时候可以平滑过渡。

使用云函数服务需要绑什么域名?​

使用云函数(包含 hook 函数)的应用,需要绑定 API 域名。

在云引擎托管网站,则需要绑定云引擎域名。

如果你实在不确定的话,可以两个都绑一下(需要绑定不同的域名,可以是同一域名的不同子域名,例如 api.example.com 和 web.example.com),这样就万无一失了。

文件域名因为备案信息变更,绑定域名时会报错提示「域名已冻结」。​

如果文件域名在工信部有备案信息变更,或者有文件域名注销后重新备案的情况,绑定域名时会报错「域名已冻结」。这种情况可以通过工单联系我们申请解冻。

开发版应用也需要接入备案么?​

商用版应用、开发版应用使用的 API 自定义域名和云引擎自定义域名都需要接入备案(同一域名下的不同子域名无需重复接入备案)。开发版应用需要先购买独立 IP,然后通过工单提交接入备案所需材料。

我是开发版应用,但不想购买独立 IP,还能办理接入备案么?​

接入备案申请中需要提交 IP 地址信息。名下有商用版应用的开发者,我们会赠送独立 IP。 如名下无商用版应用,你需要自行购买独立 IP。 目前我们无法协助没有独立 IP 的应用办理接入备案。

如果以后退订了备案时使用的独立 IP,会发生什么?​

如果管局或底层 IaaS 服务商抽查到 IP 与接入备案的域名不符,会限令整改甚至撤销接入备案。建议不要退订备案使用的独立 IP,除非相应域名已不再使用。

开发版应用无法提交工单?​

之前工单仅向商用版应用开放,现在为了协助开发版应用办理接入备案,工单系统也向开发版应用开放,不过开发版应用仅能在「接入备案」分类下提交工单。

部署云引擎的服务端项目,如果自定义域名请求接口有报错:Provisional headers are shown​

该报错是大部分原因是云引擎中绑定自定义域名使用自己上传的 SSL 证书有问题,可以使用如下两个 SSL 证书检测工具输入云引擎中绑定的域名然后进行检测:

如果检查结果为: 检测结果提示“服务器缺少中间证书”或“证书链不完整”,可以进入 https://myssl.com/chain_download.html 进行证书修复;